OVNI Ship Explorer

OVNI Ship Explorer

OVNI Ship Explorer for Poser 9 or above.
Model with lower polygons to complete SCI-FI scenes.

Software: Poser Pro 2010+, Poser Pro 2014 & Game Dev, Poser 9+

Requirements:  Poser 9 or above

Renderosity
Props for Poser and Daz Studio